Welcome, Guest. Please Login or Register
UGENE Bulletin Board
  Welcome to our forum.
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Cannot add annotation into exported genbank file (Read 1907 times)
Oct 4th, 2016 at 5:42pm

Malvolio   Offline
YaBB Newbies

Posts: 12
*
 
When I export sequences from a CAP3 alignment as a *.gb file and try to add annotations, I cannot save them directly in the file, only in a separate document (MyDocument.gb by default). Looks like the *.gb file is created without a pre-existing annotation table.

Steps to reproduce the bug:

1) create an alignment of sequence results using CAP3 (I have included a sample *.ace file to this post)
2) select a sequence in the alignment (e.g. assembled contig), then RMB>Export>Save sequence, format Genbank, trim gap characters
3) open the *.gb file in UGENE and try to add an annotation (e.g. through search menu); the only available option is "Create new table" (in a separate file)

Expected: Option Save annotations to ... existing annotation table  should be also available.

I use 64 bit UGENE 1.24.2 from Ubuntu repository.
 

pUC19_ctg_cap.ace (22 KB | 95 )
IP Logged
 
Reply #1 - Oct 17th, 2016 at 7:05pm

Olga Golosova   Offline
YaBB Administrator

Posts: 265
*****
 
Hi!

Indeed, this is not very user-friendly. We will fix this in the next version.

For now to create a single GenBank file that contain the sequence and the annotations, you may select the corresponding sequence and annotation objects (located in the different documents) in the project view and export them to a new file:
1) Select "Export/Import > Export sequences"
2) In the appeared dialog set "File format to use" to "GenBank", make sure "Export with annotations" checkbox is checked.

Thanks for your feedback!
 
IP Logged
 
Reply #2 - Oct 18th, 2016 at 7:00pm

Malvolio   Offline
YaBB Newbies

Posts: 12
*
 
Thanks a lot! I will try that out.
 
IP Logged
 
Page Index Toggle Pages: 1