Welcome, Guest. Please Login or Register
UGENE Bulletin Board
  Welcome to our forum.
Page Index Toggle Pages: 1
Spades error code 1 (Read 5228 times)
Jan 10th, 2017 at 9:42pm

jerry   Offline
YaBB Newbies

Posts: 2
Lubunt 16.04.1 64bit (on Hyper-V)
24 vCPU, 64Gb RAM
UGENE 1.25.0
Python 2.7 + Python 3.5 (fron Ubuntu repo)
Spades 3.9.1 (binary from spades website)|Spades 3.6.0 (from Ugene ext-tools) (I've tried both)
./spades.py --test  runs OK.
Pair-ended MySeq reads
all setting by defaults.
I'm getting error code 1
No way to provide any useful debug info ;(
Such problem was on some previous release of Ugene. It was solved by using CLI for SPades
About 2 months ago everything was okay @out-of-box@
Now the problem is again.
Is there any detailed logs or smth of this king to find out the reason?

Thanks in advance.

https  ://mail.nniiem.ru/owncloud/s/PsMInc7W8XFNDrl

yaml, generated by Ugene+SPades 3.9.1
https  ://mail.nniiem.ru/owncloud/s/yysb1bAqQVUZ1xU

IP Logged
Reply #1 - Jan 11th, 2017 at 5:26pm

Olga Golosova   Offline
YaBB Administrator

Posts: 302
Hi Jerry!

Thanks for the detailed report!

All SPAdes log messages would be available in the UGENE Log View, if you check "TRACE" and "DETAILS" items on the Logging tab of the UGENE Application Settings. That's how you can track the SPAdes execution progress in the current UGENE version.

I'll try to check the issue using the files you sent and write you again.
IP Logged
Reply #2 - Jan 13th, 2017 at 8:54am

jerry   Offline
YaBB Newbies

Posts: 2
Accoring to logs, problem can be in two points:
1. Due to the fact, that I use Russian translation of GUI in UBuntu, sereral folders are named in rus (Документы etc).
2. In Ugene GUI k-mer are set to text val "auto", while spades cli is expecting set of coma-separated ints.

I've used my files with spades cli and manual k-mer setting... it is ok, so the problem is in how ugene forms cli command for spades.
IP Logged
Reply #3 - Jan 13th, 2017 at 3:55pm

Denis Kandrov   Offline
YaBB Administrator

Posts: 24
Hello, Jerry!

We have found the cause of this problem.

When you use Russian translation of GUI in dialog "Сборка генома de novo" the parameter "размеры k-mer (-k)" is set "авто". So, as a workaround, you should change it to "auto" and then click "Start".

Now we have fixed this problem and in the next release this issue should not repeat.
IP Logged
Page Index Toggle Pages: 1