Welcome, Guest. Please Login or Register
UGENE Bulletin Board
  Welcome to our forum.
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
I can't open ugene (Read 346 times)
Aug 8th, 2018 at 4:31am

you   Offline
YaBB Newbies

Posts: 2
*
 
I have a problem with ugene
I can't lunch ./ugene -ui
He start the lunch and after nothing. I can't see ugene application.
when i try an other comand line  -->> ./ugeneui
i have this nottification :
./ugeneui: error while loading shared libraries: libU2Core.so.1: cannot open shared object file: No such file or directory


I work with gentoo x64 and i use ugene 1.30
please how i can find the solution for this problem ?

 
IP Logged
 
Reply #1 - Aug 9th, 2018 at 4:28pm

Alexey Tiunov   Offline
YaBB Administrator

Posts: 8
*****
 
Hello.

We need additional information. Please, answer the following questions:

1. Does the command "./ugene -ui" print anything to the terminal? There should be an error message.

2. After the first step execute in another terminal
Code:
ps -ax | grep ugeneui 


Is there process ugeneui in the process list?

3. It is possible that you've downloaded 32-bit version of UGENE. Execute
Code:
file ugeneui 


and post the output here.

You can try to do the following actions:
1. You can try to launch ugeneui directly again. To do this the environment variable should be set before the launching:
Code:
LD_LIBRARY_PATH=$PWD ./ugeneui 



2. If you have used UGENE in the past, try to remove settings file:
Code:
rm -f ~/.config/Unipro/UGENE.ini 

 
IP Logged
 
Reply #2 - Aug 10th, 2018 at 8:52pm

you   Offline
YaBB Newbies

Posts: 2
*
 
I follow your advices and it is the same i can't open.
Code:
root ~ # ps -ax |grep ugeneui
 3235 pts/0  Sl+  0:00 /root/ugene-1.30.0/ugeneui
 3247 pts/1  S+  0:00 grep --colour=auto ugeneui 




Code:
 root ~/ugene-1.30.0 # file ugeneui
ugeneui: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.26, BuildID[sha1]=a0788d72b8f7547b4787407c088dfaff95052c06, stripped 

 
IP Logged
 
Reply #3 - Aug 14th, 2018 at 7:51pm

Alexey Tiunov   Offline
YaBB Administrator

Posts: 8
*****
 
As I can see, UGENE is in the process list, but you don't see it. May be there are some troubles with your windows manager. What windows manager do you use?

Let's force UGENE to write log to the file. Execute the following command:
Code:
UGENE_PRINT_TO_FILE=ugene_log.txt ./ugene -ui 


Then wait for a minute. After that kill the UGENE process. Attach the log file to the post.
 
IP Logged
 
Page Index Toggle Pages: 1