Welcome, Guest. Please Login or Register
UGENE Bulletin Board
  Welcome to our forum.
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Circular DNA, partial sequence copied (Read 161 times)
Nov 8th, 2019 at 2:40pm

Marek   Offline
YaBB Newbies

Posts: 4
*
 
Hi,

I have an issue where whenever I'm trying to copy sequence that goes through the last and the first base (e.g. 1..8,9561..9575) I only get a part of it in the clipboard, up to the last/first bp (i.e. just 1..8 instead of whole sequence).

What is more, if I have any kind of annotation going through the last and first base I can't select it by double clicking on the plasmid map. It's possible to select it in details view and zoom view. However, in zoom view, only a part of the annotation is selected depending whether you're selecting with view zoomed at the beginning or end of the plasmid. And again if I try to copy the whole annotation, I only get part of it.

Last, when doing in silico PCR that spans the last and first bases, it does work and it shows me the correct amplified fragment with it's length and region in the in silico PCR window. However, when I click on Extract porducts(s) what I get is 39b.p. sequence instead of the correct one. What is more, when trying to copy the selection region it is again too short (only copies up to/from the beginning of the plasmid).

I've tried looking around the forum and there seems to be an issue with selections/annotations that span the last and first base in circular sequences that's been there for a while. I would be grateful if you could fix that bug.

UGENE version 1.32.0, 64-bit running on Windows 10

Edit:
I also just noticed that the calculated length in the In silico PCR isn't correct, it's 4 bases to long (the region it selects is correct though).
 
IP Logged
 
Reply #1 - Nov 12th, 2019 at 4:21pm

Olga Golosova   Offline
YaBB Administrator

Posts: 310
*****
 
Thank you very much for the feedback! We'll carefully test all scenarios you mentioned.
 
IP Logged
 
Reply #2 - Nov 29th, 2019 at 4:54pm

Olga Golosova   Offline
YaBB Administrator

Posts: 310
*****
 
Hi Marek.

We've tried to reproduce the issues you reported. We've noticed a few other issues with circular DNA, but not the ones you describe.

May I ask you to describe the exact scenario(s) for each problem? As a sample data you may use, for example, "PBR322.gb" file , located in the "/data/samples/GenBank" subfolder of the UGENE installation folder, so that we try to repeat the scenarios using the same data.
 
IP Logged
 
Reply #3 - Dec 3rd, 2019 at 4:19pm

Marek   Offline
YaBB Newbies

Posts: 4
*
 
Hi Olga,

Sorry for the delay in getting back to you. With the sample plasmid from the installation folder it seems to be working fine. However, I managed to replicate what I get with a sample sequence from Addgene (addgene.org/browse/sequence_vdb/2557/).

Issue 1:
Select 1..2,5309..5310. Add annotation. When you try to select the annotation (double click) on the circular plasmid map it won't let you do it.
When you select it in the zoom view (double click), it only selects a part of it.
To select the whole sequence and be able to copy it you have to select from annotations window, only then it seems to copy fine.

Issue 2:
For the PCR problem I realized that I was putting forward and reverse primers the other way round. However, still when using the following pair:
1)GCTCTCCCTTATGCGACTCC
2)GCGTCCCATTCGCCAATCC
there is some kind of a bug. When you put 1 as forward and 2 as reverse (mismatches 0, 3' perfect match 15bp, max product 5000bp, extract annotations inner), in the window it shows product with a length of 642 bp. When you click to extract products it gives you 39bp long primers joined together.
This doesn't happen when you switch the primers around (1 as reverse, 2 as forward). I've also tried with other primers but the issue doesn't occur.

I hope that helps.

Edit:
I know that's a bit off topic but didn't know if it's worth a separate thread. Is there a way to make DNA sequences circular in workflow designer? I was trying to extract PCR products for multiple plasmids but it doesn't seem to find the products that span the first and last base.
 
IP Logged
 
Reply #4 - Dec 3rd, 2019 at 6:46pm

Olga Golosova   Offline
YaBB Administrator

Posts: 310
*****
 
Thanks, Marek! We'll check this.
 
IP Logged
 
Reply #5 - Dec 4th, 2019 at 1:39pm

Olga Golosova   Offline
YaBB Administrator

Posts: 310
*****
 
Hi Marek,

Issue 1 should be already fixed in the latest UGENE v.33.

We were able to reproduce issue 2 and is going to fix it before the next v. 34.

Thanks for your feedback!
 
IP Logged
 
Page Index Toggle Pages: 1